Aras Innovator client has failed to initialize.

rated by 0 users
This post has 8 Replies | 5 Followers

Top 100 Contributor
Posts 21
Points 315
Florent Duranton Posted: Mon, Jun 18 2012 9:52 AM

Hi,

 

I have this "Aras Innovator client has failed to initialize" issue only on ie8 but not on ie9.

I have followed this http://www.aras.com/support/documentation/9.3.0/Installation%20and%20Configuration/Aras%20Innovator%209.3%20-%20Internet%20Explorer%20Client%20Machine%20Configuration.pdf but nothing change, I have also use the Manual .NET Security Config Tool [sdns.exe utility] but nothing change.

Maybe someone can help, thanks

  • | Post Points: 20
Top 500 Contributor
Posts 3
Points 50

The usual pitfalls:

-Did you start sdns.exe as administrator?

-You need to copy sdns.exe to the local disk of the client (no network drive).

-Do you run the 32-bit version of IE.

-Did you check the .NET and MSXML versions on your client?

These are the usual suspects, if a client here does not wok.

Hope this helps,

Cheers, Michael

There are 10 types of people in world: those who understand binary, and those who don't.

  • | Post Points: 20
Top 100 Contributor
Posts 21
Points 315

Hi,

thanks but I have done all of these point.

 

  • run sdns.Exe as administrator (directly on the client disk)
  • install msxml 4
  • .NET 4 is already installed
  • run the 32-bit version of IE

 

What I don't understand is the following : when I try to reach Aras when I'm on the server with http://localhost/InnovatorServer/Client/ it works but on the same server with the url http://myServer/InnovatorServer/Client/ it doesn't work even if I have add myServer to ie trusted site.

It seems that the sdns utility change the .NET 2 security policies, on client laptop there only is .NET 4.. maybe this is the issue?!

  • | Post Points: 20
Top 50 Contributor
Posts 37
Points 665
Anthony replied on Tue, Jun 19 2012 9:37 AM

Hi Florent,

yes, it is changing the .net security policy, in order to check these, you can go to Control Panel\System and Security\Administrative Tools open Microsoft .NET Framework 2.0 Configuration (if you do not have it install .net 2.0 sdk)

If you are running a windows 7 (or W2k8 server) .net 3.5 is installed by default (and also 2.0 by extension)

Just check that an entry exists for your website.

Note that if you access your server via myServer adress, you will need to run sdns for this url. even if localhost or 127.0.0.1 is working. The policy is based on the name of the server.

Anthony

  • | Post Points: 20
Top 100 Contributor
Posts 21
Points 315

Hi Anthony,

I have install  .net 2.0 sdk but I don't know where to search if an entry exists for my website can you help me a bit again?

Sorry I'm a bit insistent but if I'm not able to resolved it my boss will have some doubts with putting Aras into production ^^

  • | Post Points: 20
Top 50 Contributor
Posts 37
Points 665
Anthony replied on Thu, Jun 21 2012 6:09 AM

You can search in My Computer, Runtime Security Policy, Machine, Code Groups, All_Code

You should find your Aras instance (configured by sdns)

After that, open the properties  and check that your website is correctly configured : http://host/instanceName/Client/cbin/*

If you have further problems, feel free to contact me directly on skype (minerva.fr.apo) and I'll be happy to help you with that.

 

Anthony

  • | Post Points: 35
Top 10 Contributor
Posts 548
Points 8,180
Brian Pye replied on Tue, Jun 26 2012 8:22 AM

Pretty sure you need to have .Net 3.5 installed.

Having .Net 4 does not do it.

Brian.

  • | Post Points: 5
Top 100 Contributor
Posts 21
Points 315

I'm desesperated, I have done all of these things but it doesn't work.

Is it because I use an ie8 on a windows 2008 server R2 ?

I will try to find a laptop of a basic user to try to access to Aras because today, only my laptop is able to connect to our Aras server.

  • | Post Points: 20
Top 500 Contributor
Posts 5
Points 55
Stefan replied on Mon, Jul 16 2012 10:04 AM

You need to add the site URL to the 'Trusted Sites' under the security tab on IE properties panel.

You would also need to setup the "trusted sites" permissions according to the Aras Client Guide

Hope this helps

Stefan

  • | Post Points: 5
Page 1 of 1 (9 items) | RSS